
Qube Rendering at CCS
A guide to rendering using the Qube Renderfarm
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Maya/Qube
RenderFarm Instructions

In order for your Maya Project to render successfully through the Qube RenderFarm you must follow 
the ‘Maya Project Structure’. 

This means that you must create a ‘New Maya Project’ when starting a new project. It is important 
that you place your scenes in the ‘Scenes” folder within this Maya project folder, textures in the 
“SourceImages” folder, and so on. Please use short names and underscores in place of spaces when 
naming your folders, files, projects, textures, etc.

Open “This PC” - open the “Render Storage (R:)” volume.

In the (R:) volume, select File – New 
Folder. Rename this folder using your 
CCS username. (ex. Jdoe or Jdoe2)

Copy your complete project folder into 
the folder you just made with your CCS 
username.

Open Maya. Select ‘File’, and 
select Open Scene’. 

Select ‘Set Project’ 
and navigate to your 
‘Project Folder’ on 
the (R:) directory. 

 
Once your project folder is done copying, disconnect your external drive, or any other 
external media source.
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Highlight your 
‘Project Folder’ 
and click on ‘Set’. 

Open the scene 
that you want to 
render.

Best Practice: Following the previous instructions is considered a “Best Practice” standard. 
Opening Maya and setting your project folder first before opening your scene file (rather than 
double-clicking on your scene file to open Maya) ensures that your project directory will be set 
to the (R:) volume.
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Once your scene has 
opened, select ‘File’ – 
‘Project Window’ and check 
to see that your project 
settings are correct. 

The ‘Current Project’ field 
should be set to the name of 
your ‘Project Folder’ and the 
‘Location’ field should be set 
to ‘R:/YourUsername’.

Clean your scene before submitting to the Qube Renderfarm

•	 Maya’s render.exe and batchrender.exe programs do NOT like Unknown or Unused nodes 
anywhere in your scene.  A good method to properly clean a scene is to first IMPORT ALL 
REFERENCES.  While the render farm supports referencing, if your references are not 
optimized, the render will likely fail. It is easier to import everything then clean the scene, then to 
go to all your references individually and clean them one at a time.

   

•	 After your references are imported, go to your Hypershade and Delete Unused Nodes. After 
that, clean your scene using File > Optimize Scene Size.  Be warned that the Optimize Scene 
Size function can destroy your scene if you are using customized data structures  if this happens 
simply undo the operation and go through each Optimize function until you eliminate the one that 
breaks your scene. 

•	 Delete anything in your scene that is not contributing to the render.  The farm DOES NOT 
SUPPORT LIVE DYNAMICS, remove them or Cache / bake everything that is animated with 
a dynamics solution. The farm will fail with scenes that have references that are themselves 
referenced (i.e. do NOT build a renderable scene with more than ONE level of referencing!). 
Beware of overly long (256 character) namespaces. No Spaces in Filenames or file paths!  

•	 We highly recommend that you use the caching technologies that are included with Maya. The 
two major types are Autodesk Geocache and Alembic Cache. Used properly, either of these 
caching methods will help to cut down on scene errors, simplify your scene and will also speed 
up both your viewport and rendering performance. Network rendering works better when you 
give the renderer less to process. Live rigs, histories and references should be eliminated from 
the scenes that you wish to submit to render; caching is a way to streamline this process.  
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When you are ready to submit your job to the renderfarm, please make sure your Maya Project 
Structure has been properly set, your Render Globals have been set, and the camera you want 
rendered checked ‘renderable’ in the output settings. Make sure all your textures and materials are 
pointing to your Project on the R:/ volume. 

Submitting your job to the Qube Renderfarm

Once you are sure your Render Settings are 
correct, it’s now time to submit to the Qube 
Renderfarm. 

Click on the Qube menu in the Maya menubar 
and select “Submit Maya Render Job...”.

The Qube “Submit maya” window will open.
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If these settings are not correct, DO NOT CHANGE THE SETTINGS HERE. Close out the Qube 
“Submit maya” window and make your changes in your “Render Settings”; then save and reopen the 
Qube “Submit maya” window.

Notice in the Qube “Submit maya” window that all your project settings have been automatically 
populated in the appropriate fields.

If your settings are all correct, click Submit. 

Your job has now been submitted to the Qube Renderfarm. The Submit maya window will 
automatically close, and a “job ID” will come up. Record this number for future reference. 

The Qube Renderfarm manages the different render jobs one at a time. Once you submit a job, the 
Renderfarm puts it in a queue and begins rendering it once the last job is complete. 

You can see the jobs in the queue by opening the Qube UI shortcut located in the Start / Windows 
menu.

To learn about Qube UI, go to the Using the Qube UI section.

Important: Once your render job is completed, please clear out your render files from the R: 
drive within 48 hours.

If you have any questions regarding the Renderfarm, contact the Help Desk at
helpdesk@collegeforcreativestudies.edu.
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General guidelines for Maya scene submission 
•	 Optimize your scenes regularly. If you’ve optimized it, but then worked on it again… optimize it 

again. Caching helps with this.  
•	 Simplify your scene however you can. Caching helps a lot with this.  
•	 If there is something in your scene that is NOT contributing to a render (such as Hidden layers / 

geometry) then please DELETE IT.  Hiding or setting assets to ‘nonrenderable’ does nothing for 
optimization. If you don’t need it in the render, get rid of it for that scene.  

•	 Save revisions of your scene. Save a “render” version that’s been cached, baked and optimized, 
and a “live” version for continued editing.  

•	 Check your RAM levels when the scene has been loaded and with a rendered frame in the 
framebuffer.  

•	 No live dynamics. Cache / bake everything that is animated with a dynamics solution.  
•	 Make sure your scene can load & render without having to load it in via openPipeline. 

OpenPipeline is a great tool, but you have to be sure that the scene can load without it being 
resident. Before you send a scene to render make sure it can load in via Maya menu: file>open.  

•	 Did you set proper render settings? Check the render directory, file type, frame padding, 
renderable camera, resolution and renderable layers. 

•	 No spaces in folder names or file names!  
•	 Each shot is unique. Some shots need different renderer settings. What works great for one shot 

may not necessarily work for another shot. Don’t just “set it and forget it”.  
•	 Don’t set reflections to be too deep. Don’t make mirrors that reflect mirrors that refract through 

glass that reflect off mirrors, etc.  
•	 Don’t reference into references into references. You will end up creating an unrenderable and 

unrepairable scene if you do this.

General guidelines for Arnold 
•	 Use Arnold’s subdivision settings. Look in the object attributes for “Arnold” and then tweak 

“iterations”.  Don’t crank this up past 4. These settings have a direct link to render times and 
RAM usage. Too high a setting will crash the renderfarm. 

•	 Under Textures: Uncheck “Auto convert textures to TX”
•	 Use only the built-in Arnold shaders. If you’ve found a third-party shader, we can’t support it at 

this time.  
•	 The Sampling and Ray Depth settings are the core of Arnold and are directly related to render 

times. Use them wisely and carefully. Optimizing these settings on a shot-by-shot basis will 
greatly improve your efficiency. Start all your shots at value 1 for all sampling settings and only 
increase them slowly, one by one with a test render for each iteration. Increase AA samples 
before the other samples. If you can get a good image with low settings, use low settings. Don’t 
increase settings unless you absolutely need to. 

•	 Using lots of AOV’s eats up RAM. Being frugal here will pay off in shorter renders. Select what 
you will actually USE.  

•	 IN Arnold, selecting “tiled” for EXRs will help with RAM usage.  
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Adobe After Effects/Qube
RenderFarm Instructions

Open “This PC” - open the “Render 
Storage (R:)” volume. 

Right-click and select New --> Folder. 
Rename this folder using your CCS 
username. (ex. Jdoe or Jdoe2).

Copy your complete project folder into the folder you just made with your CCS username.
 
Once your project folder is done copying, disconnect your external drive, or any other 
external media source.

Open Adobe After Effects. Select File, and select Open Project. 
Navigate to your project folder on the (R:) directory, and open your After Effects file. 

Click the Edit menu --> Preferences --> 
Scripting & Expressions.

Click the checkbox next to Allow Scripts 
to Write Files and Access Network, then 
click OK.
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Click the File menu --> Scripts --> 
Qube_SetPath.jsx.

Enter the following text exactly OR copy and paste it from this guide:

C:\Program Files (x86)\pfx\qube\bin\qube.exe

Setting the path to the Qube GUI

Click OK.  It will confirm with a window 
confirming that the Qube path has been set.
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Add to Render Queue

In your project window, select the 
composition you want to render, then click 
the Composition menu --> Add to Render 
Queue.  

The Render Queue window will pop up.

The composition should now be added in 
the Render Queue window of your project.  

Ensure that the Render checkbox on the 
left of the composition you want rendered 
is checked, and all other compositions that 
you don’t want rendered are not checked.

Double-check that all of your render 
settings are correct.

Important Note: Qube will not render 
After Effects ‘.tif’ files. 

When you’re ready to submit the job, 
click the File menu --> Scripts --> 
QubeAppFinder_Submit_RenderQueue.
jsx.
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The Submit aerender window will pop 
up.

Notice that all your project settings have 
been automatically populated in the 
appropriate fields. 

If these settings are not correct, DO NOT CHANGE THE SETTINGS HERE. 

Close and make your changes in After Effects, then re-submit by going to the File menu --> 
Scripts --> QubeAppFinder_Submit_RenderQueue.jsx.

If your settings are all correct, click Submit.   

Note: If you had more than one composition checked, the Submit aerender window will 
pop up for every composition that was checked. If you didn’t mean to submit more than 
one, click Cancel for each window.

Your job has now been submitted to the Qube Renderfarm. The Submit aerender window will 
automatically close, and a “job ID” will come up. Record this number for future reference. 

Close your After Effect project file.  Do NOT open it again from the R: drive until it’s 
finished rendering.

The Qube Renderfarm manages the different render jobs one at a time. Once you submit a job, 
the Renderfarm puts it in a queue and begins rendering it once the last job is complete. 

You can see the jobs in the queue by opening the Qube UI shortcut located in the Start / 
Windows menu. 

To learn about Qube UI, go to the Using the Qube UI section.

See next page for important information when your rendered job has finished -->
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Important: Once your render job is completed, please clear out your render files from the R: 
drive within 48 hours.

If you have any questions regarding the Renderfarm, contact the Help Desk at
helpdesk@collegeforcreativestudies.edu.
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VRED/Qube RenderFarm Instructions

(Note: Use Qube Renderfarm for rendering stills and one-camera animations.
If rendering more than one camera animation, DO NOT use Qube.  

Instead, refer to the VRED Cluster Rendering Guide.)

First, navigate to This PC, then open the (R:) 
volume (called Render Storage). 

Right-click and select New --> Folder. 
Rename this folder using your CCS 
username. (ex. Jdoe or Jdoe2).

Copy your complete project folder into the folder you just made with your CCS username.
 
Once your project folder is done copying, disconnect your external drive, or any other 
external media source.

Open VRed. Select the File menu --> Open. 

Navigate to your project folder on the (R:) directory, and 
open your VRed file. 

With your project file opened, first click the Scene menu 
and select Camera Editor.
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In the Camera Editor window, 
select the camera that you want to 
render. 

You need to create a new viewpoint.  
To do this, right-click on the camera 
you selected and select Create --> 
Viewpoint.

You can rename the new 
viewpoint you’ve created.

Set and adjust all necessary 
viewpoint settings throughout 
this window to properly 
visualize how you want your 
rendering to be viewed.

When finished, close the 
window to confirm.
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Next, click the 
Rendering menu --> 
Render Settings. 

The Render Settings 
window will open.

Click the View field to select 
the camera you created your 
viewpoint in, then select the 
viewpoint you created.

In the Filename field, click the 
folder icon to navigate to your 
VRed file on the R: drive.

Note: This provides the path 
where your files will render to.

Enter in the File name field what 
you would like your rendered files to 
be named and image type.  

Click Save to confirm and return to 
the Render Settings window.
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Once your viewpoint and 
output destination are 
set, set and adjust any 
other settings throughout 
the Render Settings 
window.

Confirm all settings, then 
click the x button at the 
top-right corner to close 
the window.

Note: DON’T click any 
of the Render buttons 
on the bottom.

To submit your render job to the Qube Renderfarm, 
click the Scripts menu --> Qube.

In the small window that pops up, click on Submit 
a Viewpoint Render Job. Do NOT select any other 
choices in this submenu. Qube can only render a 
Viewpoint render job.

This will bring up the Qube Submit ViewPoint 
Render window.
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Some fields (in *red*) are 
automatically populated, specifically 
the VRED Path, VRED Project, and 
VRED Viewpoints.

You *need* to populate the other 
fields in *red*, specifically:

• Qube Frame Range

• Render Directory 

• Image File Basename
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In the Qube Frame Range --> 
Range, enter the number of frames 
you want rendered.

In the Render Directory field, click 
Browse to navigate to your username 
folder on the R: drive, where the 
frames will output to.

Highlight the folder and click OK.

The Render Directory field is now 
populated.

In the Image File Basename field, 
enter the desired output filename.

If your settings are all correct, then 
click the Submit button.

Your job has now been submitted 
to the Qube Renderfarm. A “job ID” 
will come up. Record this number for 
future reference. 

Close your VRed project file.  Do 
NOT open it again from the R: 
drive until it’s finished rendering.
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The Qube Renderfarm manages the different render jobs one at a time. 

Once you submit a job, the Renderfarm puts it in a queue and begins rendering it once the last 
job is complete.
 
You can see the jobs in the queue by opening the Qube UI shortcut located in the Start / 
Windows menu.

To learn about Qube UI, go to the Using the Qube UI section.

Important: Once your render job is completed, please clear out your render files from the 
R: drive within 48 hours.

If you have any questions regarding the Renderfarm, contact the Help Desk at
helpdesk@collegeforcreativestudies.edu.



• Best Practice:  After copying your file or project folder to the R: volume, open the application first and 
then your file or project folder.  (Do not double-click on your file to open it.)

• Before you submit your job to the Renderfarm, ensure all your scene images, textures and other 
assets are in your folder labeled with your username on the R: volume.

• Once you have copied your file or project folder to the R: volume, be sure to disconnect your external 
drive, or any other external media source before doing any test rendering.

• TEST render a few individual frames from your file located on the R: volume to the local computer 
before sending your full job to the Qube Renderfarm. This will ensure that you are not missing any 
textures, assets, etc.
 
• IF YOUR LOCAL COMPUTER CANNOT RENDER THE FILE, THE RENDERFARM WON’T BE 
ABLE TO EITHER!

• If you are satisfied with the results of a local render from the R: volume, FIRST submit a test render 
of a few frames on the Qube Renderfarm before submitting your whole job to ensure that the output is 
what you expect.

• If no frames rendered at all, there is a problem with your animation file. If the same frames are failing 
over and over again, there might be a problem in the animation settings or possibly missing textures 
that are not in the correct folder.

• SUBMIT EARLY. There may be a lot of students using the Renderfarm. The Qube Renderfarm renders 
jobs on a first-come, first-serve basis. Towards the end of the semester there will be heavy use and 
submitting jobs late will not guarantee that your job will be finished in time.

It is imperative that you follow the instructions closely in the Qube Renderfarm 
instructions booklet. Do not set or change any settings unless specifically required 
in the instructions. To do so may cause your render job to fail or take a much 
longer time to process than expected. 

IMPORTANT POINTS TO FOLLOW TO ENSURE SUCCESSFUL 
USE OF THE QUBE RENDERFARM
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Using the QUBE UI
Qube UI is software used to monitor the status of the job you submitted to the Qube Renderfarm. 

Open Qube UI by clicking on the Start / Windows menu --> PipeLineFX --> Qube UI.

1. Filter Bar - Click your User icon to only see your jobs.  Click Pending, Running, etc. to see 
only jobs that are pending, running, etc.

2. Search - Enter keywords to narrow down the jobs.

3. Jobs Pane - Section of window that shows a summary of jobs submitted to the Renderfarm.

4. Details Pane - Section with tabs such as Job Properties, Job Internals, etc. to get specific 
details of each job.

5. Component Pane - Section that shows information associated with the frames with the jobs 
selected in the Jobs Pane.

6. Frames Tab - Tab within the Component Pane, used to show specific frame output information. 
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The Jobs Pane shows a column summary of the jobs submitted to the Renderfarm. Here you will see 
the jobs that you have submitted. 

Notice the Status field for each job.  The Status indicates if the job is running, complete, failed, or if 
a job has been killed due to issues. 

The column of buttons along the left side of the Jobs Pane is a set of filters 
which will show or hide jobs.
 
When you click your user icon, you will only see your own jobs. 
Click on it again and you will see all jobs that have been submitted by other 
users. 

Click Pending, Running, Failed, etc. to show only jobs that are pending, 
running, failed, etc.
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The series of tabs in the Details Pane offer information about the currently highlighted job.  

Click on your job in the Jobs Pane to 
highlight it, then click one of the following 
tabs in the Details Pane:

Job Properties: This contains basic 
information about the job. 

It displays start time, when your job 
completed and an average time it took 
to render a frame. It also displays the 
fields specified in the submission form.

Job Internals: This shows very 
detailed information about the job, from 
submission parameters to dispatch 
history.

Stdout Log: This shows the Stdout 
(standard output) text output from the 
job highlighted in the Jobs Pane. 

To show the output for a specific 
frame, highlight the specfic frame 
in the Frame Tab. The search bar 
underneath allows searching for text in 
the log.

Stderr Log: This shows the Stderr 
(standard error) text output from the 
job highlighted in the Jobs Pane. 

To show the output for a specific frame, 
highlight the frame in the Frame Tab to 
the right. The search bar underneath 
allows searching for text in the log.

Preview: This shows a scrubbable 
preview of the selected job’s output.

Thumbnails: This feature is not 
available for all image formats at this 
time, such as “.exr” files.
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•   It is imperative that you follow the instructions closely in the Qube Renderfarm 
instructions booklet. 

• Do not set or change any settings unless specifically required in the 
instructions. To do so may cause your render job to fail or take a much longer 
time to process than expected. 

If you have any questions regarding the Qube Renderfarm, contact the Help Desk at
helpdesk@collegeforcreativestudies.edu.

If after submitting your job to the 
Renderfarm, you notice in the Details 
Pane that there are problems with your 
job (such as missing textures, etc.), you 
can stop your job.

Right-click on the job and select Kill 
Job.  

Once you have fixed the problem in your project, you will have to re-submit the job.
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NOTES



• Best Practice:  After copying your file or project folder to the R: volume, open the application first and 
then your file or project folder.  (Do not double-click on your file to open it.)

• Before you submit your job to the Renderfarm, ensure all your scene images, textures and other 
assets are in your folder labeled with your username on the R: volume.

• Once you have copied your file or project folder to the R: volume, be sure to disconnect your external 
drive, or any other external media source before doing any test rendering.

• TEST render a few individual frames from your file located on the R: volume to the local computer 
before sending your full job to the Qube Renderfarm. This will ensure that you are not missing any 
textures, assets, etc.
 
• IF YOUR LOCAL COMPUTER CANNOT RENDER THE FILE, THE RENDERFARM WON’T BE 
ABLE TO EITHER!

• If you are satisfied with the results of a local render from the R: volume, FIRST submit a test render 
of a few frames on the Qube Renderfarm before submitting your whole job to ensure that the output is 
what you expect.

• If no frames rendered at all, there is a problem with your animation file. If the same frames are failing 
over and over again, there might be a problem in the animation settings or possibly missing textures 
that are not in the correct folder.

• SUBMIT EARLY. There may be a lot of students using the Renderfarm. The Qube Renderfarm renders 
jobs on a first-come, first-serve basis. Towards the end of the semester there will be heavy use and 
submitting jobs late will not guarantee that your job will be finished in time.

It is imperative that you follow the instructions closely in the Qube Renderfarm 
instructions booklet. Do not set or change any settings unless specifically required 
in the instructions. To do so may cause your render job to fail or take a much 
longer time to process than expected. 

IMPORTANT POINTS TO FOLLOW TO ENSURE SUCCESSFUL 
USE OF THE QUBE RENDERFARM

Important: Once your render job is completed, please clear out your render files from the R: 
drive within 48 hours.

If you have any questions regarding the Renderfarm, contact the Help Desk at
helpdesk@collegeforcreativestudies.edu.


